Проблема - версия протокола

 
+
-
edit
 

google

новичок
Здравствуйте у меня такая проблема, поднял я свой сервак l2j, пробывал как балансера, так и l2j.sf.unstable.
Ко мне не могут подключится люди из-за старой версии клиента.
В логах пишется - Client is not using latest Authentication method.

Заставить всех обновлять клиент я не могу, так как у многих людей, которые будут у меня играть трафик платный. А если просто вырезать папку system из проапдейченного клиента, то l2 ругается на поврежденные файлы... раньше так можно было делать, но теперь (в последних апдейтах) требуется заменять файлы и в прочих папках.
Я пробывал изменить версию протокола хекс-редактором в engine.dll, но l2j всё-равно ругался и на то, что из этого получалось.

Ах да, понижение в серверном конфиге MinProtocolRevision ничего не даёт.
Я так понимаю l2j вообще отказывается работать с клиентами ниже версии 551.

Что делать?
Подскажите, может как-то можно отключить проверку...
 
+
-
edit
 

masterXL

разработчик OpenWorlds
minprotocol=560
maxprotocol=659
Трудно быть богом... Не веришь? Спроси любого админа! можешь спросить у меня 175506816 ServerIP=193.41.172.19 Перенос доступен  
+
-
edit
 

google

новичок
А дефолт l2_c3_installer - 530 :((((
Значит никак?
 
+
-
edit
 

DeltaQ

новичок
А дефолт l2_c3_installer - 530 :((((
Значит никак?
 

Поставь minprotocol=529
вметсо minprotocol=560
Тока помему если протакол ниже 556 то пати работать не будут.
 

tazik

новичок
У меня с клиентом 530 отказывался работать даже если ставить MinProtocol=0/MaxProtocol=1000.
Наверно там как то сильно отличается механизм авторизации/протокол, и дело даже не в проверке.
та3  
AD Реклама Google — средство выживания форумов :)
+
-
edit
 

google

новичок
вот вот.. у меня тоже самое
Причём дело скорее всего не в огромных различиях протоколов, а простом "упрямстве" l2j
 

в начало страницы | новое
 
Поиск
Настройки
Твиттер сайта
Статистика
Рейтинг@Mail.ru