Промблема при старте сервера.

 
RU C[1]mple][ #13.06.2007 21:15
+
-
edit
 

C[1]mple][

новичок
Собираю сервер из разных сборок,написал файл build.xml всё компилируется отлично,но при старте сервера выводится ошибка:(что-то вроде неудаётся найти главный класс).
Exception in thread "main" java.lang.NoClassDefFoundError: net/sf/l2j/loginserver/LoginServerz
Кто в этом разбирается подскажите как исправить,файл build.xml прилагается.
Прикреплённые файлы:
build.xml (скачать) [4,77 кбайт, 96 загрузок] [attach=58612]
 
 
 
UA SoulKeeper #14.06.2007 03:19
+
-
edit
 

SoulKeeper

разработчик L2J Fortress

net/sf/l2j/loginserver/LoginServerz
Разыскивается десятка с два датапакеров :) http://la2.wrk.ru/forum/viewtopic.php?id=50882  
RU C[1]mple][ #14.06.2007 14:17
+
-
edit
 

C[1]mple][

новичок
В данном случае это опечатка.

Вот код батника для запуска:
code text
  1. @echo off
  2. :start
  3. echo Starting L2J Login Server.
  4. echo.
  5.  
  6. SET OLDCLASSPATH=%CLASSPATH%
  7. call setenv.bat
  8.  
  9. java -Dfile.encoding=UTF-8 -Xmx64m net.sf.l2j.loginserver.LoginServer
  10.  
  11. SET CLASSPATH=%OLDCLASSPATH%
  12. ..................
 
RU Diаmond #14.06.2007 14:41  @C[1]mple][#14.06.2007 14:17
+
-
edit
 

Diаmond

втянувшийся

Тебе не смогут помочь, не видя исходники. Просто имя или путь к классу в батнике не совпадают с реальными.
 
UA SoulKeeper #14.06.2007 16:39
+
-
edit
 

SoulKeeper

разработчик L2J Fortress

А использовать параметр -cp религия не позволяет? Надо выпендриццо :)?
Разыскивается десятка с два датапакеров :) http://la2.wrk.ru/forum/viewtopic.php?id=50882  

в начало страницы | новое
 
Поиск
Настройки
Твиттер сайта
Статистика
Рейтинг@Mail.ru